[WordPress] 外掛分享: JAZ-X PHP Security Guardian

首頁 › 外掛目錄 › JAZ-X PHP Security Guardian
全新外掛
安裝啟用
—
尚無評分
2 天前
最後更新
—
問題解決
WordPress 6.0+ PHP 7.4+ v1.0.2 上架:2026-10-25

外掛標籤

開發者團隊

⬇ 下載最新版 (v1.0.2) 或搜尋安裝

① 下載 ZIP → 後台「外掛 › 安裝外掛 › 上傳外掛」
② 後台搜尋「JAZ-X PHP Security Guardian」→ 直接安裝(推薦)
📦 歷史版本下載

原文外掛簡介

JAZ-X PHP Security Guardian is a free administrator-only security advisory dashboard. It helps site owners check whether their PHP version meets the upstream fixes published on October 21, 2026 for CVE-2026-109618 and CVE-2026-109619.
Features:

Shows PHP runtime version and compares it to the published patched releases for PHP 8.2, 8.3, 8.4, and 8.5.
Warns administrators when their PHP release is below the upstream fix threshold.
Provides links to official PHP security guidance.
Shows cached WordPress core, theme, and plugin update counts.
Shows WP_DEBUG and PHP display_errors configuration status.
Lets administrators record a hosting provider’s written backport or mitigation statement without treating it as independently verified.
Optionally sends administrator emails when a potentially affected PHP runtime is newly detected or its reported version changes, using WordPress cron.
Keeps all checks read-only; no automatic file modifications, remote scans, or PHP version changes.

Important limits:

This plugin does NOT patch PHP vulnerabilities or block exploit traffic. Some exploits can run before WordPress loads.
A version-number comparison alone cannot determine whether a host has vendor backports or external mitigations.
A patched PHP version does not imply a WordPress site is entirely secure.
The included CVE thresholds are a reviewed static snapshot, not a live vulnerability database. Future advisories require plugin updates.
WordPress cron depends on site activity and is not a guaranteed exact-time security alert mechanism.

延伸相關外掛

文章
Filter
Mastodon